
  

DataSuite and DatPass 
Administration Software 
Validation Manual  
Supporting Fourtec Data Loggers 
 
For compliance with the United States Food and Drug 
Administration Title 21 Code of Federal Regulations Part 11 
and with GAMP 5 

Revision 2.0 
Copyright © Fourtec – Fourier Technologies 2013 
 
Document Approval 
 
Date:  
1 January, 2013 
Signatory:  
 

 
Ilan Citrin 
Product Manager 
Fourtec – Fourier Technologies 
 
 
 
 
 
 
 
 
 
 
 

www.esis.com.au
Ph  02 9481 7420
Fax 02 9481 7267
esis.enq@esis.com.au



  

Table of Contents 
 
Chapter 1: Introduction .............................................................................................. 1 
Chapter 2: What is Title 21 CFR Part 11? ................................................................. 2 

Title 21 CFR Part 11 Definitions ............................................................................. 2 

Fourtec Software ................................................................................................... 2 

Chapter 3: Compliance with Title 21 CFR Part 11 ..................................................... 3 
References ............................................................................................................ 8 

Chapter 4: DatPass Validation Tests ......................................................................... 9 
1 - Initial Login ....................................................................................................... 9 

2 - File Menu .......................................................................................................... 9 

3 - Administration ................................................................................................. 10 

4 – Help ............................................................................................................... 13 

5 - Toolbar Icons .................................................................................................. 14 

Chapter 5: DataSuite Validation Tests ..................................................................... 15 
1 - Login .............................................................................................................. 15 

2 - File Menu ........................................................................................................ 16 

3 – DataNet Network Menu .................................................................................. 17 

4 - Tools Menu ..................................................................................................... 17 

5 – Devices Menu ................................................................................................ 26 

6 – Analysis Menu ............................................................................................... 27 

7 – Report Menu .................................................................................................. 28 

8 – Help Menu ..................................................................................................... 30 

9 – Upper Toolbar Icons ...................................................................................... 30 

10 - Graph Toolbar .............................................................................................. 32 

11 – Table View ................................................................................................... 34 

12 – Statistics View .............................................................................................. 35 

13 – Map View / Logger Configuration ................................................................. 36 

14 – Change Password dialog ............................................................................. 46 

www.esis.com.au
Ph  02 9481 7420
Fax 02 9481 7267
esis.enq@esis.com.au



 
 

 - 1 - 

Chapter 1: Introduction 
This manual will guide you through the process of validating the DatPass and 
DataSuite software package together with Fourtec data loggers to GAMP 5 and FDA 
Title 21 CFR Part 11 guidelines. This manual will provide users with a test plan for 
their own performance and operational qualification of DatPass and DataSuite and 
the Fourtec hardware. 
  
The manual comprises several sections, describing the relevant FDA Title 21 CFR 
Part 11 regulations and the implementation of these regulations in the Fourtec 
software package. In addition, this manual provides the necessary test sheets for 
DatPass and DataSuite software as well as the Fourtec loggers.  
It is important to understand that the implementation of these guidelines is not the 
sole responsibility of Fourtec. The user must undertake a large portion of the 
responsibility through the appropriate validation tests. 
 
The software package consists of two programs:  

 DatPass – DataSuite administration application 

 DataSuite – Data acquisition and analysis application, supporting the DataNet 
wireless system (in addition to other Fourtec loggers). 

 
Supported hardware includes: 

 DataNet wireless acquisition system 

 DaqLink standalone data logger 

 MicroLite USB data logger 

 MicroLogPRO II portable data logger 

 PicoLite disposal USB data logger 
 
To validate the software package, start by testing DatPass, followed by DataSuite. 
Some of these tests assume that the user is familiar with the Windows interface in 
addition to the DatPass and DataSuite software. 
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Chapter 2: What is Title 21 CFR Part 11? 
The Food and Drug Administration (FDA) issued the regulations Title 21 Code of Federal 
Regulations Part 11. These regulations provide criteria for acceptance by FDA, under certain 
circumstances, of electronic records, electronic signatures, and handwritten signatures 
executed to electronic records as equivalent to paper records and handwritten signatures 
executed on paper. The regulations apply to all FDA program areas, and are intended to 
permit the widest possible use of electronic technology, compatible with FDA’s responsibility 
to promote and protect public health. Part 11 applies to any record governed by an existing 
FDA predicate rule that is created, modified, maintained, archived, retrieved, or transmitted 
using computers and/or saved on durable storage media. 

Title 21 CFR Part 11 Definitions 

Electronic Record 

Any combination of text, graphics, data, audio, pictorial or other information representation in 
digital form, that is created, modified, maintained, archived, retrieved or distributed by a 
computer system. 

Electronic Signature 

A computer data compilation of any symbol or series of symbols, executed, adopted or 
authorized by an individual to be the legally binding equivalent of the individual’s handwritten 
signature. 

Digital Signature 

An electronic signature based upon cryptographic methods of originator authentication, 
computed by using a set of rules and a set of parameters such that the identity of the signer 
and the integrity of the data can be verified. 

Closed System 

An environment in which system access is controlled by persons who are responsible for the 
content of electronic records that is on the system. 

Open System 
An environment in which system access is not controlled by persons who are responsible for 
the content of electronic records that is on the system. 

Standard Operating Procedures (SOPs) 
Guidelines and rules defined by the organization implementing Title 21 CFR Part 11 
compliance to instruct users what they are and are not permitted to do and how they are to 
perform the relevant tasks. 

Fourtec Software 
The dual program software package achieves compliance with FDA Title 21 CFR Part 11 
with: DataSuite and DatPass. The DatPass software is the administration software, which 
includes features that define the users that can log into the DataSuite software, their 
passwords and the digital signatures the users are permitted to sign data within electronic 
records (files). The DataSuite software is used to access the electronic records, display the 
logger data, analyze the data and allow the user to add the appropriate digital signatures to 
the electronic records, in addition to other features.  
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Chapter 3: Compliance with Title 21 CFR Part 11 
 
Title 21 CFR Part 11 Requirements Comments on Compliance or Requirements 

§11.10 Controls for Closed Systems 
(a) Validation of systems to ensure 

accuracy, reliability, consistent 
intended performance, and the 
ability to discern invalid or 
altered records. 

Yes DataSuite will not open invalid or 
altered data.  

(b) The ability to generate accurate 
and complete copies of records 
in both human readable and 
electronic form suitable for 
inspection, review, and copying 
by the agency. 

Yes To ensure data integrity, DataSuite 
stores data with specific formats (.dat 
and .dnp). Data can be exported to 

Excel and stored in common formats, 
such as an Excel workbook or for 
example comma delimited or tab 
delimited. Only through the (dat) 
formats can data be read back into 
DataSuite and only these formats 
support electronic signatures. 

(c) Protection of records to enable 
their accurate and ready 
retrieval throughout the records 
retention period. 

N/A The customer chooses which data 
directory to save files to. Otherwise, the 
default directory 
C:\Users\Public\Fourtec\DataSuite\Data 
Files for DataSuite data is used. 
System owners must establish their 
own SOPs to protect and restore data 
files. 

(d) Limiting system access to 
authorized individuals. 

Yes For limited access, the customer must 
purchase a valid software license and 
dongle device, preventing access to 
unauthorized users. 

(e) Use of secure, computer-
generated, time- stamped audit 
trails to independently record the 
date and time of operator entries 
and actions that create, modify, 
or delete electronic records. 
Record changes shall not 
obscure previously recorded 
information. Such audit trail 
documentation shall be retained 
for a period at least as long as 
that required for the subject 
electronic records and shall be 
available for agency review and 
copying. 

Yes Every action that generates or alters an 
electronic record (dat and dnp), 
automatically generates an entry into 
an encrypted log file, which can be 
used in audit trail. The entries are 
chronologically organized and cannot 
be edited or deleted. The entries can 
only be viewed using the DatPass 
software. It is the system owner's 
responsibility to create SOPs to protect 
and restore audit trail files. 

(f) Use of operational system 
checks to enforce permitted 
sequencing of steps and events, 
as appropriate 

Yes A smart and user friendly interface 
ensures all DataSuite operations follow 
a specified order. This ensures all 
stages are followed.  
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Title 21 CFR Part 11 Requirements Comments on Compliance or Requirements 

(g) Use of authority checks to 
ensure that only authorized 
individuals can use the system, 
electronically sign a record, 
access the operation or 
computer system input or output 
device, alter a record, or perform 
the operation at hand. 

Yes When using DataSuite, users logon 
with a valid username and password. 
All actions are recorded in an 
encrypted audit trial log file. 

(h) Use of device (e.g. terminal) 
checks to determine, as 
appropriate, the validity of the 
source of data input or 
operational instruction. 

Yes DataSuite checks the status of the 
logger at each communication – errors 
are automatically reported. 

(i) Determination that persons who 
develop, maintain, or use 
electronic record/electronic 
signature systems has the 
education, training, and 
experience to perform their 
assigned tasks. 

N/A System owners must provide their 
authorized users with relevant training. 

(j) The establishment of, and 
adherence to, written policies 
that hold individuals accountable 
and responsible for actions 
initiated under their electronic 
signatures, in order to deter 
record and signature 
falsification. 

N/A System owners must develop written 
policy in which reliability and 
responsibility of each user is 
documented. 

(k) Use of appropriate controls over 
systems documentation 
including:  

  

(k)(1) Adequate controls over the 
distribution of, access to, and 
use of documentation for system 
operation and maintenance. 

N/A The DataSuite and DatPass package 
for Title 21 CFR Part 11 compliance are 
supplied with detailed user guides., 
which can be used to create SOP. 
Distribution, access and 
implementation of this documentation 
are the responsibility of the system 
owner. 

(k)(2) Revision and change control 
procedures to maintain an audit 
trail that documents time- 
sequenced development and 
modification of systems 
documentation. 

N/A This is the responsibility of the system 
owner. 

§11.30 Controls for Open Systems 
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Title 21 CFR Part 11 Requirements Comments on Compliance or Requirements 

 Persons who use open systems 
to create, modify, maintain, or 
transmit electronic records shall 
employ procedures and controls 
designed to ensure the 
authenticity, integrity, and, as 
appropriate, the confidentiality of 
electronic records from the point 
of their creation to the point of 
their receipt. Such procedures 
and controls shall include those 
identified in §11.10, as 
appropriate, and additional 
measures such as document 
encryption and use of 
appropriate digital signature 
standards to ensure, as 
necessary under the 
circumstances, record 
authenticity, integrity, and 
confidentiality. 

N/A Datasuite has been implemented as a 
closed system. 

§11.50 Signature Manifestations 
(a) Signed electronic records shall 

contain information associated 
with the signing that clearly 
indicates all of the following: 

  

(a)(1) The printed name of the signer; Yes Stored and printed data contains: User 
login name, time/date stamp, and user 
signature meaning(s).  

(a)(2) The date and time when the 
signature was executed; 

Yes  

(a)(3) The meaning (such as review, 
approval, responsibility, or 
authorship) associated with the 
signature 

Yes  

(b) The items identified in 
paragraphs (a)(1),(a)(2), and 
(a)(3)of this section shall be 
subject to the same controls as 
for electronic records and shall 
be included as part of any 
human readable form of the 
electronic record (such as 
electronic display or printout). 

Yes Electronic signatures in DataSuite are 
subject to the same requirements as 
electronic records. Electronic 
signatures can be viewed electronically 
and can be included on a printout. 

§11.70 Signature/Record Linking 
 Electronic signatures and 

handwritten signatures executed 
to electronic records shall be 
linked to their respective 
electronic records to ensure that 
the signatures cannot be 
excised, copied or otherwise 
transferred so as to falsify an 
electronic record by ordinary 
means. 

Yes In DataSuite, raw data and electronic 
signatures are permanently linked in a 
single file, and as such cannot be 
edited, deleted or separated. 
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Title 21 CFR Part 11 Requirements Comments on Compliance or Requirements 

§11.100 General Requirements 
(a) Each electronic signature shall 

be unique to one individual and 
shall not be reused by, or 
reassigned to, anyone else. 

Yes DatPass software contains an 
authorized user list containing login 
name, password, and meanings list, 
making every user unique to the 
system. 

(b) Before an organization 
establishes, assigns, certifies or 
otherwise sanctions an 
individual's electronic signature, 
or any element of such 
electronic signature, the 
organization shall verify the 
identity of the individual. 

N/A This is the responsibility of the system 
owner. 

(c) Persons using electronic 
signatures shall, prior to or at the 
time of such use, certify to the 
agency that the electronic 
signatures in their system, used 
on or after August 20, 1997, are 
intended to be the legally 
binding equivalent of traditional 
handwritten signatures. 

N/A This is the responsibility of the system 
owner. 

(c)(1) The certification shall be 
submitted in paper form, and 
signed with a traditional 
handwritten signature, to the 
Office of Regional Operations 
(HFC-100),5600 Fishers Lane, 
Rockville, MD 20857.  

N/A This is the responsibility of the system 
owner. 

(c)(2) Persons using electronic 
signatures shall, upon agency 
request, provide additional 
certification or testimony that a 
specific electronic signature is 
the legally binding equivalent of 
the signer's handwritten 
signature. 

N/A This is the responsibility of the system 
owner. 

§11.200 Electronic Signature Components and Controls 
(a) Electronic signatures that are 

not based upon biometrics shall: 
  

(a)(1) Employ at least two distinct 
identification components such 
as an identification code and 
password. 

Yes DatPass Software for Title 21 CFR Part 
11 compliance uses a unique dual 
component combination: Login 
username and password. Every login 
and new digital signature with 
DataSuite requires a valid username 
and password. DataSuite enforces the 
user to re-logon after a time period, 
which is defined by the administrator 
via the DatPass software. 
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Title 21 CFR Part 11 Requirements Comments on Compliance or Requirements 

(a)(1)(i) When an individual executes a 
series of signings during a 
single, continuous period of 
controlled system access, the 
first signing shall be executed 
using all electronic signature 
components; subsequent 
signings shall be executed using 
at least one electronic signature 
component that is only 
executable by, and designed to 
be used only by, the individual 

Yes  

(a)(1)(ii) When an individual executes 
one or more signings not 
performed during a single 
continuous period of controlled 
system access, each signing 
shall be executed using all of the 
electronic signature 
components. 

Yes  

(a)(2) Be used only by their genuine 
owners; 

N/A Information confidentiality is the 
responsibility of the system owner and 
users. 

(a)(3) Be administered and executed 
to ensure that attempted use of 
an individual's electronic 
signature by anyone other than 
its genuine owner requires 
collaboration of two or more 
individuals. 

N/A Information confidentiality is the 
responsibility of the system owner and 
users. 

(b) Electronic signatures based 
upon biometrics shall be 
designed to ensure that they 
cannot be used by anyone other 
than their genuine owners. 

N/A Biometrics are not the basis of 
electronic signatures generated by 
DatPass software for Title 21 CFR Part 
11 compliance.  

§11.300 Controls for Identification Codes/Passwords 
 Persons who use electronic 

signatures based upon use of 
identification codes in 
combination with passwords 
shall employ controls to ensure 
their security and integrity. Such 
controls shall include: 

  

(a) Maintaining the uniqueness of 
each combined identification 
code and password, such that 
no two individuals have the 
same combination of 
identification code and 
password. 

Yes Since every user is unique in the 
DataSuite and DatPass systems, 
duplicate combinations of username 
and password are impossible. 

(b) Ensuring that identification code 
and password issuances are 
periodically checked, recalled, or 
revised, (e.g. to cover such 
events as password aging). 

Yes Adequate aging of passwords is the 
responsibility of the system owner. 
DataSuite allows authenticated users to 
change their own logon password.  
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Title 21 CFR Part 11 Requirements Comments on Compliance or Requirements 

(c) Following loss management 
procedures to electronically 
deauthorize lost, stolen, missing, 
or otherwise potentially 
compromised tokens, cards, and 
other devices that bear or 
generate identification code or 
password information, and to 
issue temporary or permanent 
replacements using suitable, 
rigorous controls. 

N/A Unauthorized access is vetoed by the 
DatPass software since an 
administrator can disable or remove 
any user from the system. 

(d) Use of transaction safeguards to 
prevent unauthorized use of 
passwords and/or identification 
codes, and to detect and report 
in an immediate and urgent 
manner any attempts at their 
unauthorized use to the system 
security unit, and, as 
appropriate, to organizational 
management.  

Yes All unsuccessful logons are recorded in 
the audit trail log file. 

(e) Initial and periodic testing of 
devices, such as tokens or 
cards, that bear or generate 
identification code or password 
information, to ensure that they 
function properly and have not 
been altered in an unauthorized 
manner. 

N/A This is the responsibility of the system 
owner. 

References 
For further information on FDA Title 21 CFR Part 11, please visit the FDA website: 
www.fda.gov 
For FDA guidance documents: 
www.fda.gov/ora/compliance_ref/part11/ 
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Chapter 4: DatPass Validation Tests 
 

1 - Initial Login 
Following DatPass installation, you will be required to start the 30-day free trial period 
or to activate the software using the unique product serial number supplied with the 
software CD. Until either of these actions is performed, the user won’t be able to 
login to DatPass.  

Note: Following installation, the first user to login to the DatPass software is 
automatically assigned the user name Admin. He is classified as an Administrator.  

 

Test # Test Description Expected Result Result 

1.1 Double click the DatPass 
shortcut on the Desktop. 

Verify that the User Login dialog box 
opens. 

 

1.2 Click New User in the login 
window. 

a. Verify that the New User Login 
window opens. 

b. Verify that the New User drop-
down menu displays the Admin 
user name. 

 

1.3 a. Populate the New User 
ID, Confirm User ID, 
New Password and 
Confirm Password fields, 
and click OK. 

b. Exit the DatPass 
software. 

c. Launch the DatPass 
software. 

a. Once DatPass is launched, 
verify that the User Login 
window opens. 

b. Verify that the newly created 
User ID and User Password are 
correct (click OK and verify 
successful login to DatPass). 

 

 

2 - File Menu 
 

Test # Test Description Expected Result Result 

2.1 On the File menu, click Open. 
Navigate to: 
C:\Users\Public\Fourtec\DatPass.  
Note: You will only find database 
files saved in this directory if 
previous database data, such as 
the Audit Trail log, has been 
saved. 

a. Verify that the Open 
dialog box opens.  

b. Select a file to open, 
and click Open. 

c. Verify that the 
database file (file 
extension .mdb) 
opens, and the table 
data is displayed in 
the main DatPass 
window.  

 

2.2 On the File menu, click New. Verify that the DatPass main 
window is clear of all previous 
Audit Trail data. 
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Test # Test Description Expected Result Result 

2.3 On the File menu, click Print. 
Note: For this action to succeed, 
the main DatPass window must 
be populated with Audit Trail log 
data.  

Verify that the Print Dialog dialog 
box opens. 

 

2.3.1 In the Print Dialog dialog box: 
a. Select Portrait or Landscape 

orientation. 
b. Using the From and To fields, 

define the date and time 
range to print. 

c. Click OK. 

Verify that the Print dialog box 
opens.  
 

 

2.3.2 In the Print dialog box, confirm 
that the correct printer is selected 
in the Name drop-down menu 
and click OK. 

Verify that the graph was printed 
with the specific date and time 
range (as defined in test 2.3.1), 
at the selected printer. 

 

2.4 On the File menu, click Print 
Setup. 

Verify that the Print Setup dialog 
box opens. 

 

2.5 On the File menu, click Log Off. Verify that the User Login dialog 
box opens. 

 

3 - Administration 

 
Test # Test Description Expected Result Result 

3.1 On the Administration 
menu, click User 
Administration.  

a. Verify that the User 
Administration dialog box opens. 

b. Verify that Admin appears under 
the User Name tab and 
Administrator appears under the 
Group tab.  
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Test # Test Description Expected Result Result 

3.1.1 a. In the User 
Administration dialog 
box, click Add User. 

b. Enter a new user name 
in the User Name field. 

c. Select a Group from the 
Group drop-down menu: 
Administrator, Approver, 
or User. 

Under the Login Settings 
heading: 
d. Enter a number in the 

Password min length 
field (for example, 4). 

e. Enter a number in the 
User ID min length field 
(for example, 4). 

f. Enter number of days in 
the Password expiration 
time (days) field (for 
example, 1). 

g. Use the drop-down 
menu in the Inactivity 
Timeout field to select 
the duration (for 
example, 00:05:00). 

h. Click OK. 

Verify that a new user has been 
added to the User Administration 
dialog box, listing the correct User 
Name and Group. 

 

3.1.2 a. Launch the DatPass 
software and add click 
New User.  

b. Using the new user 
account created in test 
3.1.1, fill in the New User 
ID, Confirm New User 
ID, New Password and 
Confirm Password fields.  

c. Click OK.  

Verify that the DatPass software 
opens. 

 

3.1.3 Launch the DatPass 
software. In the User Login 
dialog box: 
a. Enter an incorrect user 

name and a correct 
password. 

b. Enter a correct user 
name and an incorrect 
password. 

c. Enter an incorrect user 
name and password.  

Verify that in all three login tests, the 
DatPass software does not open. 
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Test # Test Description Expected Result Result 

3.2 In the User Administration 
dialog box, select the newly 
added user (see test 3.1.1) 
and click Properties. 

a. Verify that the User Properties 
dialog box opens. 

b. Verify that the properties entered 
when adding the user (in test 
3.1.1) are correct. 

 

3.2.1 a. In the User Properties 
dialog box, change the 
user group using the 
drop-down menu in the 
Group field. For 
example, from User to 
Approver). 

b. Click OK.  

Verify that the user group was 
successfully changed by reopening 
the User Properties dialog box and 
checking the Group field.  

 

3.2.2 a. In the User Properties 
dialog box, change the 
Login Settings. 

b. Click OK. 

Verify that the Login Settings were 
successfully changed by reopening 
the User Properties dialog box and 
checking the relevant Login 
Settings.  

 

3.3 In the User Administration 
dialog box, select a user and 
click Deactivate. 

Verify that the user icon is now 
marked with a white cross in a red 

background, as follows:   

 

3.3.1 Open the DatPass software 
and attempt to login with the 
user name and password of 
the newly deactivated user.  

Verify that a dialog box opens with 
the message:  
Your user account was deactivated. 
Please refer to your system 
administrator. 

 

3.3.2 a. In the User 
Administration dialog 
box, select the 
previously deactivated 
user and click Activate. 

b. Exit DatPass, then 
reopen DatPass and 
login with the user name 
and password of the 
newly activated user. 

Verify that you are able to 
successfully login to DatPass.  

 

3.3.3 a. In the User 
Administration dialog 
box, select a user and 
click Renew Password. 

b. Exit DatPass, and then 
reopen DatPass and 
attempt to login with that 
user. 

a. Verify that a new DatPass dialog 
box opens with the message:  
Your password was reset. 
Please enter a new password. 

b. After clicking OK, verify that a 
new Change Password dialog 
box opens. 

 

3.3.4 a. In the Change Password 
dialog box, enter a new 
password and then 
confirm this password. 

b. Click OK. 

Verify that the DatPass software 
opens. 
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Test # Test Description Expected Result Result 

3.3.5 Launch the DatPass 
software and login using the 
user name and new 
password created in step 
3.3.4. 

Verify that the DatPass software 
opens. 

 

3.4 On the Administration 
menu, click Group 
Administration.  

a. Verify that the Group 
Administration dialog box opens. 

b. Verify that the group names 
User, Approver and 
Administrator are displayed. 

 

3.4.1 In the Group Administrator 
dialog box, click Add Group. 

Verify that the Group Properties 
dialog box opens. 

 

3.4.2 a. In the Group Properties 
dialog box, enter a new 
name in the Group 
Name field. 

b. Click the New check box. 
c. Click OK. 

a. Verify that the Group 
Administration dialog box opens. 

b. Verify that the newly created 
group is displayed in the Group 
Name list. 

 

3.4.3 In the Group Administrator 
dialog box, select the newly 
created group and click 
Properties. 

Verify that there is only one check 
box selected (in this case, New).  

 

3.4.4 In the Group Administrator 
dialog box, select one of the 
listed groups and click 
Remove Group. 
Note: You will not be able to 
remove a group if there are 
still users who are members 
of this group. 

a. Verify that a dialog box opens 
with the message:  
Are you sure you want to 
remove <Group Name> group? 

b. Click Yes. 

 

3.4.5 On the Administration 
menu, click Group 
Administration.  

Verify that the group you have 
removed is no longer displayed in 
the Group Name list. 

 

 

4 – Help 

Test # Test Description Expected Result Result 

4.1 On the Help menu, click 
DatPass User Guide.  

Verify that the DatPass v4.0 User 
Guide is opened (file name: User 
Guide.pdf) 

 

4.2 On the Help menu, click 
Register. 

a. Verify that the Validata – 
Product Validataion window is 
opened. 

b. DatPass will either be in the Trial 
mode, or will already be 
activated. 

 

4.3 On the Help menu, click 
About DatPass.  

a. Verify that DatPass version 
4.0.0.0 is displayed. 

b. Verify the link 
http://www.Fourtec.com works. 
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5 - Toolbar Icons 
 

Test # Icon Test and Expected Result Result 

5.1 Open 

 

Refer to test 2.1.  

5.2 Print 

 

Refer to test 2.3.  

5.3 User Administration 

 

Refer to tests 3.1 to 3.3.  

5.4 Group Administration 

 

Refer to test 3.4.   

5.5 Refresh  

 

a. Perform at least one action in 
the MicroLab software and click 
Refresh. 

b. Verify that the Audit Trail data 
has been refreshed (you will see 
new actions added to the table). 
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Chapter 5: DataSuite Validation Tests 
 
This Validation document is designed for the DataSuite software running any of the 
following products:  

 DataNet wireless acquisition system 

 DaqLink standalone data logger 

 MicroLite USB data logger 

 MicroLogPRO II portable data logger 

 PicoLite disposal USB data logger 
 

Note: The DataSuite validation tests must be performed by a user with full 
Administrator privileges, as defined by the DatPass software. Otherwise, it will not be 
possible to execute all tests described in this chapter. 

1 - Login 

Test # Test Description Expected Result Result 

1.1 a. Launch the DataSuite 
software from the 
desktop shortcut. The 
User Login dialog box 
opens. 

b. In the User ID field, enter 
the User ID created in 
test 1.3 of the DatPass 
Validation Test. 

c. In the User Password 
field, enter an incorrect 
password. 

Verify that the DataSuite software 
does not open and an Incorrect 
Password message window 
opens. 

 

1.2 a. In the User Login dialog 
box, in the User ID field, 
enter an incorrect User 
ID.  

b. In the User Password 
field, enter the User 
Password created in test 
1.3 of the DatPass 
Validation Test. 

Verify that the DataSuite software 
does not open and an Incorrect 
User ID message window opens. 

 

1.3 In the User Login dialog box, 
enter an incorrect User ID 
and User Password.  

Verify that the DataSuite software 
does not open and an Incorrect 
User ID message window opens. 

 

1.4 In the User Login dialog box, 
login using the User ID and 
User Password created in 
test 1.3 of the DatPass 
Validation Test. 

Verify that the DataSuite software 
is launched. 
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2 - File Menu 

Test # Test Description Expected Result Result 

2.1 Click Open. Verify that the Open Data Files 
window is opened. 

 

2.1.1 In the Open Data Files 
dialog box, select a logger 
according to its Serial 
Number or Comment and 
select the data set using the 
From: and To: fields.  

Verify that the selected data set 
from the specific logger opens, 
and that the appropriate data is 
displayed in the graph and table in 
the History View window. 

 

2.2 From the History View 
window, with at least one 
data set open, go to File 
menu and click Save 
Project. Enter the project 
name in the Save As dialog 

Verify that the project has been 
saved in the selected location.  

 

2.2.1 Click Open Project Files 
and browse to the location of 
a previously created 
DataSuite project file. Click 
Open. 

Verify that the DataSuite project is 
opened in the History View 
window, with the relevant data 
from all loggers in the selected 
project.  

 

2.3 Click Backup System Files 
and enter the system 
password.  

Verify that the Backup System 
Files window is opened. 

 

2.3.1 Select the option to backup 
the system files to a folder 
on the computer. Browse to 
the relevant folder (or create 
a new folder) and click OK. 

Verify that a progress bar 
indicates that the system files are 
being backed up.  
When complete the message 
Done will appear below the 
progress bar. 

 

2.3.2 Open the folder in which the 
system files were backed 
up. 

Verify that a file which the 
extension .BackUp is found, with a 
creation timestamp of when this 
feature was executed.  

 

2.4 Click Restore System Files 
and enter the system 
password. 

Verify that the Restore System 
Files window is opened. 

 

2.4.1 Select the option to restore 
the system files from a folder 
on the computer. Browse to 
the folder that was selected 
in bullet 2.3.2 above, in 
which the system files are 
located, and click OK.  

Verify that the Available Restore 
Points window is opened. 

 

2.4.2 From the Available Restore 
Points window, select the 
relevant backup file and click 
OK. 

Verify that a progress bar 
indicates that the system files are 
being restored from the selected 
restore point.  
When complete the message 
Done will appear below the 
progress bar. 
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Test # Test Description Expected Result Result 

2.4.3 The user will be prompted to 
restart the computer in order 
to complete the restore 
process. Click Yes. 

Verify that the computer is 
restarted. Login to DataSuite and 
confirm the system settings are 
intact. 

 

2.5 Click Print Map View. 
Proceed with the Windows 
print setup and click Print. 

Verify that the current Map View 
background has been printed. 

 

2.6 Click Log Off.  Verify that the Login window is 
opened, indicating that the user 
has been logged out of DataSuite.  

 

2.7 Click Exit. Verify that the DataSuite software 
is closed. 

 

3 – DataNet Network Menu 
Ensure that the DataNet Receiver is already detected by the DataSuite software, and 
that at least one DataNet logger or Repeater has joined the network before carrying 
out these tests. 
 

Test # Test Description Expected Result Result 

3.1 Click Show Network Paths.  Verify that the network paths 
between all online devices in the 
network are displayed as a green, 
yellow or red path. 

 

3.2 Click Refresh Network 
Connections. 

Refer to the Receiver icon tool tip 
and verify that the Refresh 
Network Connections command is 
in queue and is processed by the 
Receiver. 

 

4 - Tools Menu 
 

Test # Test Description Expected Result Result 

4.1 Select Define Sensor. Verify that the Defined Sensors 
dialog is opened. 

 

4.1.1 Click New to enable 
adding a new sensor. In 
the Sensor Properties 
fields, enter a Sensor 
name and Sensor unit, and 
select the relevant option 
from the Base sensor and 
decimal digits menus. 
 
Enter the relevant values in 
the Define Values fields. 
 
Click Save. 

Verify that all properties have 
been entered correctly in the 
Defined Sensor dialog. 
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Test # Test Description Expected Result Result 

4.1.2 Go to the Setup window of 
an online data logger and 
in the Sensor type drop-
down menu, select the 
Sensor name as defined in 
4.1.1. 

Verify that the Sensor name 
appears in the drop-down menu.  

 

4.1.3 Send the setup to the 
logger, including the 
defined sensor name on 
one of the logger inputs. 

Verify that the Sensor name 
appears in the Logger icon tool 
tip when sampling data, with the 
correct values.  

 

4.2 Go to the Sensor View with 
online loggers sampling 
data. On the Tools menu, 
select Switch Sensor 
View Mode.  

Verify that the Sensor boxes 
switch between large and small 
sizes. 

 

4.3 Click Lock Map View 
ensuring there is a check 
mark next to this menu 
item. 

Verify that the icons on the Map 
View cannot be moved and are 
locked in position. 

 

4.3.1 Unselect the check mark 
next to the Lock Map View 
menu item. 

Verify that the icons on the Map 
View can be moved freely 
around the Map View window. 

 

4.4 Select Options. Verify that the Options dialog 
opens. 

 

4.4.1 Options > Preferences Tab Tests 
 
Click the Preferences tab to commence the testing of this tab. 

4.4.1.1 Select the check box next 
to the Minimize application 
to System tray option. 
Minimize the DataSuite 
application. 

Verify that the application has 
been minimized and the 
DataSuite icon appears in the 
Windows system tray. 

 

4.4.1.1.1 Double click the DataSuite 
icon in the system tray. 

Verify that the DataNet 
application is opened. 

 

4.4.1.2 Select the check box next 
to the Run application on 
Windows startup option. 

Verify that after resetting the 
computer, DataSuite is 
automatically launched. 

 

4.4.1.3 Toggle the Map View 
background options 
between Stretch and 
Center. 

Verify that the Map View 
background image is centered 
or stretched, depending on the 
option selected. Depending on 
the background image there 
might not be any noticeable 
difference. 

 

4.4.1.4 In the Set decimal places 
for option, select a sensor 
input and change the 
number of decimal places 
from the default selection. 

Verify that for the selected input, 
the value is now displayed in a 
resolution according to the 
number of decimal places 
selected. 
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Test # Test Description Expected Result Result 

4.4.1.5 Change the Date Format to 
one of the options 
available in the drop-down 
menu. 

When viewing online or offline 
data, verify that the date 
appears according to the date 
format selected.  

    

4.4.1.6 Change the path where the 
DataSuite data files are 
saved by clicking Browse 
next to the Application data 
files path option. Browse to 
the new path and click OK. 

Once the path has been 
changed, wait for data to be 
downloaded from at least one 
logger on the network. Go to the 
new path and verify that a folder 
named using the logger serial 
number has been created there, 
and that data files are contained 
within this folder.  

 

4.4.1.7 Select the Save text data 
files option. 

Download data from at least one 
logger, and verify that text files 
containing logger data have 
been created in the path 
displayed under the Save text 
data files option.  

 

4.4.1.7.1 Change the path where the 
DataSuite text data files 
are saved by clicking 
Browse next to the Save 
text data files option. 
Browse to the new path 
and click OK. 

Once the path has been 
changed, download data from at 
least one logger. Go to the new 
path and verify that the text files 
have been created there. 

 

4.4.1.8 Change the path where the 
Report files are saved by 
clicking Browse next to the 
Path for Report files option. 
Browse to the new path 
and click OK. 

Once the path has been 
changed, create a DataSuite 
report and verify that the report 
Excel or PDF file has been 
created there. 

 

4.4.2 Options > Device Settings Tab 
 
Click the Device Settings tab to commence the testing of this tab. 

4.4.2.1 Ensure the Download data 
on application startup 
option is selected. 

Verify that when you next 
launch the DataSuite 
application, assuming there is 
an online logger detected by the 
software, data is automatically 
downloaded. 

 

4.4.2.2 Ensure the Generate and 
send Boomerang reports 
automatically option is 
selected. 

Verify that when you connect a 
MicroLite II, MicroLogPRO II or 
PicoLite logger to the computer, 
with DataSuite open and the 
Boomerang feature already 
configured on the logger, a 
Boomerang report is 
automatically generated by 
DataSuite and is emailed to the 
defined distribution list.  
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Test # Test Description Expected Result Result 

4.4.3 Options > e-mail Settings Tab 
 
Click the email Settings tab to commence the testing of this tab. 

4.4.3.1 Click Edit next to the 
Selected Profile drop-down 
menu. 

Verify that the Email Profile 
Manager opens. 

 

4.4.3.2 In the Profile List, click 
Add. 

Verify that the Profile Settings,  
Server Information and Login 
Information fields are enabled 
(not grayed out). 

 

4.4.3.3 Enter the relevant account 
settings specific to your e-
mail account. 

Verify that all the settings are 
entered correctly. 

 

4.4.3.4 Ensure the Use 
authentication login check 
box is selected and enter 
the username and 
password. If your e-mail 
account does not require 
login information this step 
may be skipped. 

Verify that these settings are 
entered correctly. 

 

4.4.3.5 After all the email account 
settings have correctly 
been entered, click the 
Test Email button. 
Select an existing email 
contact or enter a new 
email address in the 
relevant field. 

Verify that a test email from this 
account was successfully 
received by the defined contact. 

 

4.4.3.6 Click OK to return to the 
main Email Settings tab. 
In the Selected Profile 
drop-down menu, select 
the email account created 
in step 4.4.3.3. 
 
Create an alarm condition 
on one of the online data 
loggers and select a 
contact to receive an alarm 
e-mail notification in the 
event that the alarm 
threshold was breached. 

Verify that an e-mail 
notifications was sent to the 
selected contact/s. 

 

4.4.3.7 Repeat step 4.4.3.6 using 
the Default Account. 

Verify that an e-mail 
notifications was sent to the 
selected contact/s. 

 

4.4.3.8 Click Edit next to the 
Selected Profile drop-down 
menu. 
Select the newly added 
profile and click Remove. 

Verify that the email profile was 
removed from the Email Profile 
Manager window. 
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Test # Test Description Expected Result Result 

4.4.4 Options > SMS Settings Tab 
 
Click the SMS Settings tab to commence the testing of this tab. 

4.4.4.1 Select the Send SMS 
notifications check box. 

Verify that the GSM Connection 
Settings and Unlock SIM Card 
fields are enabled (not grayed 
out). 

 

4.4.4.2 In the GSM Connection 
Settings section, enter the 
relevant settings specific to 
the GSM modem you are 
using.  

Verify that all the settings are 
entered correctly. 

 

4.4.4.3 If a PIN code is needed, 
select the Use PIN code 
check box and enter the 
code. 

Verify that the Use PIN Code 
field is enabled.  

 

4.4.4.4 Click OK to apply the 
changes and close the 
Options window. Ensure 
that the GSM modem is 
properly connected to the 
computer and is powered. 

Verify that the GSM modem 
icon in the DataSuite upper tool 
bar is green, indicating modem 
connection. 

 

4.4.4.5 Create an alarm condition 
on one of the data loggers 
in the network and select a 
contact to receive an alarm 
SMS notification in the 
event that the alarm 
threshold was breached. 

Verify that an SMS notification 
was sent to the selected 
contact/s. 

 

4.5 
 

Click Manage Contacts. Verify that the Manage Contacts 
dialog is opened. 

 

4.5.1 Select the Contacts tab 
and click Add Contact. 

Verify that the Contact Details 
dialog is opened. 

 

4.5.1.1 Select the Vacation check 
box. 

Verify the From and To fields 
are enabled.  

 

4.5.1.2 Enter the relevant details in 
the Contact Details dialog 
(Name is mandatory).  
Click OK. 

Verify that the contact was 
created and is listed in the 
Contacts tab. 

 

4.5.1.3 Select the contact created 
in 4.5.1.2 and click Edit 
Contact. 

Verify that the Contact Details 
dialog is opened with the same 
details entered in 4.5.1.2. 

 

4.5.1.4 Change one of the details 
in the selected contact. 
Click OK. Click Edit 
Contact on this contact. 

Verify that the detail has in fact 
been changed. 

 

4.5.1.5 Select the contact created 
in 4.5.1.2 and click 
Remove Contact. 

Verify that the contact has been 
removed from the list. 

 

4.5.2 Select the Groups tab and 
click Add Group. 

Verify that the Group Details 
dialog is opened. 
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Test # Test Description Expected Result Result 

4.5.2.1 Enter a name in the Group 
Name field and click OK. 

Verify that the group was 
created and is listed in the 
Groups tab. 

 

4.5.2.2 Ensure at least one contact 
has been created, and 
click Edit Group. In the 
Contact section select at 
least one contact to add to 
the group. Click OK. 

Verify that the contact name has 
been added to the group by 
seeing it appear under the 
Contacts header in the Groups 
tab, next to the relevant group. 

 

4.5.2.3 Select the group created in 
4.5.2.1 and click Remove 
Group. 

Verify that the group has been 
removed from the list. 

 

4.6 Select e-Mail Alarm 
Notifications. 

Verify that the e-Mail Alarm 
Notifications dialog is launched. 

 

4.6.1 Note: Test 4.6.1 only 
applies to the DataNet 
wireless system. If using 
another system, proceed to 
4.6.2.  
 
Select the Notifications 
Setup tab. 
Select one online DataNet 
logger from the device list. 
This logger must already 
be configured with alarm 
levels defined in the Alarm 
Setup. 

Verify that for the selected 
logger, the Battery and 
Reception alarm check boxes 
are enabled, as well any check 
boxes for any other input for 
which an alarm level has been 
configured in the Alarm Setup 
process. 

 

4.6.1.1 Select the Battery Alarm 
check box. Click Contacts 
and select the contact who 
should receive e-mail 
notification of a low battery 
alarm. Click Close. 

Verify that when the battery 
level goes below 10% on the 
logger tool tip in Map View, an 
e-mail notification is received by 
the selected contact. 

 

4.6.1.2 Select the Reception Alarm 
check box. Click Contacts 
and select the contact who 
should receive e-mail 
notification of a low 
reception alarm. Click 
Close. 

Verify that when the logger goes 
offline an e-mail notification is 
received by the selected 
contact. 
Verify that when the logger goes 
back online an e-mail 
notification is also received by 
the selected contact. 
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Test # Test Description Expected Result Result 

4.6.1.3 For at least one of the 
logger inputs for which an 
alarm level has been 
defined, select the check 
box for Low, Pre-Low, Pre-
High or High alarms. Also 
select the Normalized 
check box. 
 
Click Contacts and select 
the contact who should 
receive alarm e-mail 
notification. Click Close. 

Verify that when the logger 
breaches the defined alarm 
threshold, an e-mail notification 
is received by the selected 
contact. 
Verify that when the logger 
value is normalized (not in alarm 
state), an e-mail notification is 
also received by the selected 
contact. 

 

4.6.2 Note: Test 4.6.2 applies to 
the DaqLink, MicroLite, 
MicroLogPRO II and 
PicoLite systems. If using 
DataNet, proceed to 4.6.1.  
 
Select the Notifications 
Setup tab. 
Select one online logger 
from the device list. This 
logger must already be 
configured with alarm 
levels defined in the Alarm 
Setup. 

Verify that for the selected 
logger, at least one check box 
for a logger input, for which an 
alarm level has been 
configured, is enabled. 

 

4.6.2.1 For at least one of the 
logger inputs for which an 
alarm level has been 
defined, select the check 
box for Low, Pre-Low, Pre-
High or High alarms. Also 
select the Normalized 
check box. 
 
Click Contacts and select 
the contact who should 
receive alarm e-mail 
notification. Click Close. 

Verify that when the logger 
breaches the defined alarm 
threshold, an e-mail notification 
is received by the selected 
contact. 
Verify that when the logger 
value is normalized (not in alarm 
state), an e-mail notification is 
also received by the selected 
contact. 
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Test # Test Description Expected Result Result 

4.7 Select SMS Alarm 
Notifications. 

Verify that the SMS Alarm 
Notifications dialog is launched. 

 

4.7.1 Note: Test 4.7.1 only 
applies to the DataNet 
wireless system. If using 
another system, proceed to 
4.7.2.  
 
Select the Notifications 
Setup tab. 
Select one online DataNet 
logger from the device list. 
This logger must already 
be configured with alarm 
levels defined in the Alarm 
Setup. 

Verify that for the selected 
logger, the Battery and 
Reception alarm check boxes 
are enabled, as well any check 
boxes for any other input for 
which an alarm level has been 
configured in the Alarm Setup 
process. 

 

4.7.1.1 Select the Battery Alarm 
check box. Click Contacts 
and select the contact who 
should receive SMS 
notification of a low battery 
alarm. Click Close. 

Verify that when the battery 
level goes below 10% on the 
logger tool tip in Map View, an 
e-mail notification is received by 
the selected contact. 

 

4.7.1.2 Select the Reception Alarm 
check box. Click Contacts 
and select the contact who 
should receive SMS 
notification of a low 
reception alarm. Click 
Close. 

Verify that when the logger goes 
offline an SMS notification is 
received by the selected 
contact. 
Verify that when the logger goes 
back online an SMS notification 
is also received by the selected 
contact. 

 

4.7.1.3 For at least one of the 
logger inputs for which an 
alarm level has been 
defined, select the check 
box for Low, Pre-Low, Pre-
High or High alarms. Also 
select the Normalized 
check box. 
 
Click Contacts and select 
the contact who should 
receive alarm SMS 
notification. Click Close. 

Verify that when the logger 
breaches the defined alarm 
threshold, an SMS notification is 
received by the selected 
contact. 
Verify that when the logger 
value is normalized (not in alarm 
state), an SMS notification is 
also received by the selected 
contact. 
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Test # Test Description Expected Result Result 

4.7.2 Note: Test 4.7.2 applies to 
the DaqLink, MicroLite, 
MicroLogPRO II and 
PicoLite systems. If using 
DataNet, proceed to 4.7.1.  
 
Select the Notifications 
Setup tab. 
Select one online logger 
from the device list. This 
logger must already be 
configured with alarm 
levels defined in the Alarm 
Setup. 

Verify that for the selected 
logger, at least one check box 
for a logger input, for which an 
alarm level has been 
configured, is enabled. 

 

4.7.2.1 For at least one of the 
logger inputs for which an 
alarm level has been 
defined, select the check 
box for Low, Pre-Low, Pre-
High or High alarms. Also 
select the Normalized 
check box. 
 
Click Contacts and select 
the contact who should 
receive alarm SMS 
notification. Click Close. 

Verify that when the logger 
breaches the defined alarm 
threshold, an SMS notification is 
received by the selected 
contact. 
Verify that when the logger 
value is normalized (not in alarm 
state), an SMS notification is 
also received by the selected 
contact. 

 

4.7.2.2 For at least one of the 
logger inputs for which an 
alarm level has been 
defined, select the check 
box for Low, Pre-Low, Pre-
High or High alarms. Also 
select the Normalized 
check box. 
 
Click Contacts and select 
the contact who should 
receive alarm SMS 
notification. Click Close. 

Verify that when the logger 
breaches the defined alarm 
threshold, an SMS notification is 
received by the selected 
contact. 
Verify that when the logger 
value is normalized (not in alarm 
state), an SMS notification is 
also received by the selected 
contact. 

 

4.8 Select Firmware Update 
Center. Enter the system 
password (default is 1234). 
 
Note: Ensure a copy of the 
logger firmware file is 
located in the DataSuite 
root directory: 
firmware.dfw.  
 

Verify that the Firmware Update 
Center dialog is launched.  
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Test # Test Description Expected Result Result 

4.8.1 Perform a firmware update 
on all online units on the 
network. 
Select the Update check 
box next to each of the 
units listed in the dialog.  

Verify that the firmware update 
process is performed on each of 
the units (never more than two 
in parallel). 

 

4.8.2 If the firmware version was 
higher than the previous 
firmware installed on the 
units, check the Firmware 
Version listed for each unit. 

Verify that the firmware version 
matches the version listed in the 
Available Firmware Versions 
section and that the unit Status 
is No Update Required. 

 

5 – Devices Menu 
 

Test # Test Description Expected Result Result 

5.1 Click Detect Device with at 
least one data logger 
connected to the computer. 

Verify that the Detect Device 
dialog opens and searches for 
devices connected to the 
computer.  

 

5.2 Click Stop All with at least 
one data logger connected 
to the computer and in Run 
mode (logger icon is green 
or red). 

Verify that all loggers that were 
running before the test are now in 
Stop mode. 

 

5.3 Click Run All with at least 
one data logger connected 
to the computer and in Stop 
mode (logger icon is grey). 

Verify that all loggers that were in 
Stop mode before the test are 
now running. 
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6 – Analysis Menu 
    

Test # Test Description Expected Result Result 

6.1 FO Pasteurization  
 
Go to File > Open and open 
the data set of at least one 
data logger measuring 
temperature.  

Verify that the data set is opened 
in the History View. 

 

6.1.1 Select Functions’ 
Parameters and ensure the 
displayed parameters are 
correct.  
 
Then, select a temperature 
plot on the graph.  
Select FO Pasteurization 
from the Analysis menu.  

Verify that the FO Pasteurization 
level is added to the graph. 
Histogram Settings dialog opens. 

 

6.2 Dew Point 
 
Go to File > Open and open 
the data set of at least one 
data logger measuring 
temperature and relative 
humidity. 

Verify that the data set is opened 
in the History View. 

 

6.2.1 Select a temperature or 
humidity plot on the graph. 
Select Dew Point from the 
Analysis menu. 

Verify that the Dew Point plot is 
added to the graph. 

 

6.3 Histogram 
 
Go to File > Open and open 
the data set of at least one 
data logger.  

Verify that the data set is opened 
in the History View. 

 

6.3.1 Select a plot on the graph 
and select Histogram from 
the Analysis menu. 
 
Enter the relevant Histogram 
settings and click OK. 

Verify that the Histogram was 
created according to the defined 
settings. 

 

6.4 Mean Kinetic Temperature 
 
Go to File > Open and open 
the data set of at least one 
data logger measuring 
temperature. 

Verify that the data set is opened 
in the History View. 

 

6.4.1 Select a temperature plot on 
the graph and select MKT 
from the Analysis menu. 
 
Ensure the parameters are 
correct and click Calculate.  

Verify that the MKT dialog opens, 
and calculates the MKT status. 
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Test # Test Description Expected Result Result 

6.4.2 Click Print and proceed with 
the print procedure.. 

Verify that the MKT results are 
printed correctly. 

 

6.5 Open a data set in History 
View and select Export to 
Excel. 

Verify that the selected data set is 
opened in an Excel file. 

 

6.6 Open a data set in History 
View and select Export to 
CSV. 
In the Save As dialog enter 
the file name and click Save 
in the desired location. 

Verify that the selected data set is 
opened in a CSV file and was 
saved in the correct location. 

 

7 – Report Menu 
 

Test # Test Description Expected Result Result 

7.1 Go to Reports > Reports 
Profile Manager. Enter the 
system password (default: 
1234). 

Verify that the Reports Profile 
Manager is launched. 

 

7.2 Click Create New Profile 
and select the Enable 
Report Profile checkbox. 

Verify that a new profile name has 
been entered to the profile list on 
the left of the window, and that the 
profile settings are enabled. 
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Test # Test Description Expected Result Result 

7.3 Define the report profile by 
configuring the following 
standard settings:  

 Profile Name 

 Report Generated By 

 Report Comment 

 Report Format – select 
Excel and PDF 

 Send Report by Email – 
click Generated Report 
and define a contact by 
clicking the Contacts 
button. 

 Report Type – select at 
least one of the options 
e.g. Sensors Graph 

 Report Time - define the 
time and frequency 
when the report should 
be sent e.g. Daily, or 
select the User Defined 
option to generate the 
report immediately. 

 Units – Select the units 
which should appear in 
the report. Select all 
listed units, or specific 
units. 

 
Click Save Profile when the 
configuration is complete. 
If the Report Time was set to 
User Defined, click the 
Generate Report button. 
Otherwise, click Close to 
exit the window. 

If the Report Time was set to User 
Defined, verify that the Report 
Generation progress bar was 
activated.  
Go to Report > Report Browser, 
and under the relevant Profile 
Name, verify that the new report is 
listed and includes the data in 
accordance with the selected 
Report Type and Units. 
 
If the Report Time was set to 
Daily, Weekly or Monthly, verify 
that at the defined time, the report 
was emailed to the preconfigured 
email contact and that the report 
includes the data in accordance 
with the selected Report Type and 
Units. 

 

7.4 Ensure the Report Profile 
Manager window is closed, 
and then reopen this 
window. Select the Profile 
created in 7.3. 

Verify that the profile parameters 
as defined in 7.3 have been 
saved. 
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8 – Help Menu 
 

Test # Test Description Expected Result Result 

8.1 Select User Guides > 
DataSuite.  

Verify the DataSuite User Guide 
PDF file is opened. 

 

8.2 Select Check for Updates. Verify the Check for Updates 
dialog is opened. 

 

8.1.1 Click Next to commence the 
update process.  

Verify that the update application 
has established connection with 
the Fourtec server and confirms if 
new software or firmware is 
available, or if the system is 
currently up to date. 

 

8.2 Select Language. Verify that the Language dialog is 
opened with at least one language 
pack available. 

 

8.3 Select Register and click on 
the product module. 

Verify that the Validata Product 
Validation window opens. 

 

8.3.1 Click on each of the product 
modules being validated 
using this document, and 
including the CFR module.  

Verify that each module is 
activated with a Serial Number or 
is in Trial mode. 

 

8.4 Click About. a. Verify that the About 
DataSuite opens. 

b. Verify that the DataSuite 
version is FDA 21 CFR Part 
11 compatible, v2.0.5.0 or 
higher. 

c. Verify the link 
www.Fourtec.com works. 

 

9 – Upper Toolbar Icons 
 

Test # Icon Test Description and Expected 
Result 

Result 

9.1 Open File 

 

Click this icon and verify the Open Data 
Files dialog opens. 

 

9.2 Map View 

 

Click this icon and verify the Map View 
is displayed in the main window. 

 

9.3 Sensor View 

 

Click this icon and verify the Sensor 
View is displayed in the main window. 

 

9.4 History View 

 

Click this icon and verify the History 
View is displayed in the main window. 

 

9.5 Run All 

 

Click this icon with at least one logger 
connected and in Stop mode. Verify that 
the logger is now in Run mode. 

 

9.6 Stop All 

 

Click this icon with at least one logger 
connected and in Run mode. Verify that 
the logger is now in Stop mode. 

 

http://www.fourtec.com/
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Test # Icon Test Description and Expected 
Result 

Result 

9.7 Alarm Mute/Unmute 

 

 

Click the Mute icon  and verify when 
an alarm is activated the software alarm 
is muted (through the computer 
speakers). 

Click the Unmute  icon and verify 
when an alarm is activated the software 
alarm is muted (through the computer 
speakers). 
 

 

9.8 e-mail Alarm 
Notifications 

 

Click the icon and verify the e-mail 
Alarm Notifications dialog opens. 
 

 

9.9 SMS Alarm Notifications 

 

Click the icon and verify the SMS Alarm 
Notifications dialog opens. 
 

 

9.10 GSM modem indicators 

 

 

Connect the GSM modem according to 
section 4.9 and verify the icon is green 
when the modem is connected. Verify 
the icon is grey when the modem is 
disconnected. 

 

9.11 Alarm Reason 

 

Create an alarm condition with at least 
one logger. The Alarm Reason icon will 
then flash red indicating there is an 
alarm which must be assigned a 
Reason (a CFR requirement).  
Click the icon and verify that each alarm 
that was recorded on the logger is listed 
and requiring a reason. Provide all 
requested reasons and verify that the 
icon is now disabled. 

 

9.12 Temperature - Celsius  

 

Toggle the Celsius icon and ensure all 
online temperature readings are 
displayed in C. 

 

9.13 Temperature - 
Fahrenheit  

 

Toggle the Fahrenheit icon and ensure 
all online temperature readings are 
displayed in F. 

 

9.14 Report Profile Manager 

 

Click the Report Profile Manager icon 
and enter the system password (default: 
1234). Verify that the dialog opens will 
all previously created profiles saved. 

 

9.15 Report Browser 

 

Click the Report Browser icon and verify 
that the dialog opens, listing all 
previously generated reports. 
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10 - Graph Toolbar  
This section tests the Graph toolbar which is available on the Graph tab in History 
View and Online Graph view. Icons specific to each view are noted. 
To fully test the Graph toolbar, open the data set of at least one logger via the File > 
Open menu. 
 

Test # Icon Test Description Expected Result Result 

10.1 Data Map 

  
(in History 
View only) 

Toggle the Data Map 
icon. 

Verify the Data Map is 
removed/added from the 
main window left pane. 

 

10.2 Plot Legend 

 
(in Online 
View only) 

Toggle the Plot 
Legend icon. 

Verify the plot legend is 
removed/added from the 
Online Graph view. 

 

10.3 Auto scale 

 

a. Zoom in on an area 
of the graph.  

b. Click the Auto 
scale icon  

Verify that the graph is 
restored and displayed in 
full. 

 

10.4 Zoom in 

 

a. Click the Zoom In 
icon.  

b. Click down and 
hold the left mouse 
button and drag the 
Zoom In cursor 
over the area of the 
graph to be 
zoomed.  

c. Release the left 
mouse button to 
set the zoom area. 

Verify that the selected 
area of the graph is 
zoomed in. 

 

10.5 Pan graph 

 

a. Click the Pan icon. 
b. Place the Pan 

cursor over the 
graph, hold down 
the left mouse 
button and proceed 
to pan the graph 
up, down, left and 
right.  

Verify that the graph pans 
up, down, left and right. 

 

10.6 First cursor 

 

a. Click the First 
Cursor icon. 

b. Drag the graph 
cursor to any 
coordinate on the 
graph.  

a. Verify the graph cursor 
is displayed. 

b. Verify that the chosen 
coordinate is displayed 
in the data pane 
underneath the graph. 
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Test # Icon Test Description Expected Result Result 

10.7 Second cursor 

 

a. Click the Second 
Cursor icon. 

b. Drag the graph 
cursor to any 
coordinate on the 
graph. 

a. Verify the second 
graph cursor is 
displayed. 

b. Verify that the chosen 
coordinate is displayed 
in the data pane 
underneath the graph. 

 

10.8 Grid 

 

Toggle the Grid icon. Verify the grid lines are 
added/removed from the 
graph. 

 

10.9 Time Stamps 

 

Note: Skip this test if 
using the DataNet or 
DaqLink systems.  
 
Ensure that at least 
one data set is opened 
in History View, which 
includes time stamps 
marked on the logger 
memory. The time 
stamps should be 
visible on the graph 
plot. 
Click the Time Stamps 
icon once, and then 
click the icon a second 
time. 

Verify that the time stamps 
are hidden from the graph 
plot when the icon is 
pressed, and are then 
shown when the icon is 
pressed a second time. 

 

10.10 Add Custom 
View 

 
(in History 
View only) 

Click the Add Custom 
View icon. 

Verify the customized 
graph view is added to the 
Data Map. 

 

10.11 Copy Graph 

 

Click the Copy Graph 
icon. 

Open a word processing 
application such as 
Microsoft Office Word, and 
verify that the copied graph 
can be pasted into the 
document. 

 

10.12 Graph 
Properties 

 

Click the Graph 
Properties icon. 

Verify the Graph Properties 
dialog is opened. 

 

10.12.1  In the Axis Scaling tab, 
unselect the Autoscale 
check box and enter 
the minimum and 
maximum time and 
date for the specific 
date set. Click OK. 

Verify that the scale of the 
displayed graph is 
according to the time scale 
defined. 
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Test # Icon Test Description Expected Result Result 

10.12.2  In the Axis Scaling tab, 
select the Group Plots 
by Unit check box and 
select a specific axis. 
Click OK. 

Verify that the graph axis is 
defined according to the 
selected axis. 

 

10.12.3  In the Style tab, 
unselect the Use 
default line properties 
check box. Select a 
specific axis, color and 
line width. Click OK. 

Verify that the line on the 
graph is displayed 
according to the defined 
settings. 

 

10.13 Export to 
Excel 

 

Click the Export to 
Excel icon. 

Verify that the selected 
data set is opened in an 
Excel file. 

 

10.14 Print 

 

Click the Print icon. 
In the Print dialog 
select the relevant 
printer and click OK. 

Verify the Print dialog is 
opened and that the graph 
is printed. 

 

11 – Table View 
This section tests the Table view which is available in the Table tab in History View 
and Online view.  
To fully test the table in History View, open the data set of at least one logger via the 
File > Open menu. 
To fully test the table in Online View, ensure at least one logger is detected by 
DataSuite and is running. 
 

Test # Test Description Expected Result Result 

11.1 In History View, click the Table 
tab. Click the Print icon. 

Verify the Print Table dialog is 
opened. 

 

11.1.1 In the Print Table dialog, select 
the relevant data set to be 
printed using the From and To 
drop-down menus. 
Click OK. 

Verify the Print dialog is opened.  

11.1.2 In the Print dialog select the 
relevant printer and click OK. 

Verify that the table is printed 
according to the defined data set. 

 

11.2 In Online Graph view, click the 
Table tab. Click the Print icon. 

Verify the Print Table dialog is 
opened. 

 

11.2.1 In the Print Table dialog, select 
the relevant data set to be 
printed using the From and To 
drop-down menus. 
Click OK. 

Verify the Print dialog is opened.  

11.2.2 In the Print dialog select the 
relevant printer and click OK. 

Verify that the table is printed 
according to the defined data set. 

 

11.3 Display the online data from a 
running logger and select the 
Table tab. 

Verify the logger data is updated 
in the Table view in real-time, 
according to the logger 
transmission time. 
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Test # Test Description Expected Result Result 

11.4 Time Stamps 
Note: Skip this test if using the 
DataNet or DaqLink systems.  
 
Ensure that at least one data 
set is opened in History View, 
which includes time stamps 
marked on the logger memory. 
The time stamps should be 
visible in the table column title 
Comment. 
Click the Time Stamps icon 
once, and then click the icon a 
second time. 

Verify that only the time stamps 
are displayed in the table when 
the icon is first pressed, and then 
all samples are displayed again 
when the icon is pressed a 
second time. 

 

12 – Statistics View 
This section tests the Statistics view which is available in the Statistics tab in History 
View and Online Graph view.  
To fully test the table in Statistics View, open the data set of at least one logger via 
the File > Open menu. 
To fully test the Statistics in Online View, ensure at least one logger is detected by 
DataSuite and is running. 
 

Test # Test Description Expected Result Result 

12.1 In History View, click the 
Statistics tab. Click the Print 
icon. 

Verify the Print dialog is opened.  

12.1.1 In the Print dialog select the 
relevant printer and click OK. 

Verify that the statistics are printed 
according to the statistics 
displayed in the Statistics tab. 

 

12.2 In Online Graph view, click the 
Statistics tab. Click the Print 
icon. 

Verify the Print dialog is opened.  

12.2.1 In the Print dialog select the 
relevant printer and click OK. 

Verify that the statistics are printed 
according to the statistics 
displayed in the Statistics tab. 

 

12.3 Display the online data from a 
running logger and select the 
Statistics tab. 

a. Verify the Statistics start and 
end times correspond to the 
first and last sample time in 
the Table tab.  

b. Verify the number of samples 
corresponds to the number of 
samples listed in the Table 
tab. 
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13 – Map View / Logger Configuration 
This section tests all functionality available in Map View, including the Map View 
icons functionality.  
 

Test # Test Description Expected Result Result 

13.1 Map View Background 

13.1.1 Double-click the Map View 
background to launch the 
Open dialog. Browse to a new 
background image. Select this 
image and click Open. 

Verify the image is displayed as 
the new Map View background. 

 

13.1.2 Right-click the Map View 
background and select Load 
Wallpaper. The Open dialog is 
launched. Browse to a new 
background image. Select this 
image and click Open. 

Verify the image is displayed as 
the new Map View background. 

 

13.1.3 Right-click the Map View 
background and select Reset 
Wallpaper. 

Verify the default DataSuite 
background image is displayed. 

 

13.1.4 With at least logger icon visible 
in the Map View, right-click the 
Map View background and 
select Display All Units’ 
Names. 

Verify that each logger icon now 
has a label indicating the unit’s 
name. 

 

13.2 DataNet Receiver Icon (Note: Skip this test if not using the DataNet system) 

13.2.1 Connect the DataNet Receiver 
to the computer and switch the 
Receiver on. 

Verify that the Receiver icon in 
the Map View is displayed in 
Connected (green) status.  

 

13.2.2 Ensure a copy of the DataNet 
firmware is located in the 
DataSuite root directory. 
Right-click the Receiver icon 
and select Update Firmware. 
Enter the password and 
confirm firmware update. 

a. Verify that the firmware 
update process is performed 
on the Receiver. 

b. Following the firmware 
update, confirm the firmware 
version in the Receiver 
tooltip matches the firmware 
file that was updated. 

 

13.2.3 Right-click the Receiver icon 
and select Lock Network. 
Take a DataNet data logger 
DNL910 or DNL920 and select 
the Leave Network option on 
the logger menu. Rescan for 
new networks. 

Verify that the Receiver network 
is not found during the scan 
network procedure. 

 

13.2.4 Right-click the Receiver icon 
and select Form New 
Network. 

Verify that the Receiver forms a 
new network and that the 
network ID has changed in the 
Receiver tool tip in Map View 
and on the Receiver LCD menu. 
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Test # Test Description Expected Result Result 

13.2.5 Right-click the Receiver icon 
and select Refresh Network 
Connections. 

Look at the Receiver icon tool tip 
and verify that the Refresh 
Network Connections command 
is in queue and is processed by 
the Receiver. 

 

13.2.6 Right-click the Receiver icon 
and select Show Network 
Paths.  

Verify that the network paths 
between all online devices in the 
network are displayed as a 
green, yellow or red path. 

 

13.2.7 Right-click the Receiver icon 
and select Setup. 

Verify the Receiver Setup dialog 
is opened. 

 

13.2.7.1 Change the Receiver Network 
Name and click Setup and 
Run. 

Verify the Receiver Network 
Name has been changed by 
looking at the Receiver tool-tip. 

 

13.2.8 Place the mouse cursor over 
the Receiver icon to display 
the tooltip. 

Verify the tooltip contains the 
following information: 
a. Receiver Part Number: 

DNR900 
b. Receiver Network Name 
c. Receiver Serial Number - 

matching the Serial Number 
on the rear of the unit casing 

d. Network ID – matching the 
network ID on the Receiver 
LCD menu 

e. Version – matching the 
firmware version displayed 
on the Receiver LCD menu 

 

13.3 DataNet Repeater Icon (Note: Skip this test if not using the DataNet system) 

13.3.1 Connect a Repeater to the 
DataNet network. 

Verify the online Repeater icon 
is displayed in the Map View. 

 

13.3.2 Right-click the Repeater icon 
and select Setup. 

Verify the Setup dialog is 
opened. 

 

13.3.2.1 Change the Repeater name 
and click Setup and Run. 

Verify the Repeater name has 
been changed by looking at the 
Repeater tool-tip. 

 

13.3.3 Right-click the Repeater icon 
and select Call Unit (Beep). 

Verify the Repeater unit emits a 
beep for several seconds. 

 

13.3.4 Right-click the Repeater icon 
and select Leave Network. 
Enter the default password. 

Verify the Repeater leaves the 
network and the icon disappears 
from the Map View. 

 

13.3.5 Ensure a copy of the DataNet 
firmware is located in the 
DataSuite root directory. 
Right-click the Repeater icon 
and select Update Firmware. 
Enter the password and 
confirm firmware update. 

a. Verify that the firmware 
update process is performed 
on the Repeater. 

b. Following the firmware 
update, confirm the firmware 
version in the Repeater 
tooltip matches the firmware 
file that was updated. 

 

13.3.6 Right-click the Repeater icon 
and select Show Network 
Path. 

Verify the network path between 
the Repeater and the parent 
node is displayed. 
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Test # Test Description Expected Result Result 

13.3.7 Place the mouse cursor over 
the online Repeater icon to 
display the tooltip. 

Verify the tooltip contains the 
following information: 
a. Network Name 
b. Repeater Serial Number - 

matching the Serial Number 
on the rear of the unit casing 

c. Repeater name 
d. Battery Level/Charging 

status 
e. Reception Quality 
f. Version – matching the 

firmware version displayed 
on the Receiver LCD menu 

 

13.4 DataNet Logger Icon (Note: Skip this test if not using the DataNet system)  

13.4.1 Connect a logger to the 
network. 

Verify the online logger icon is 
displayed in the Map View. 

 

13.4.2 Right-click the logger icon and 
select Setup. Select the 
Device Setup tab. 

a. Verify the Setup dialog is 
opened. 

b. Verify the Serial Number and 
Firmware version are correct 
in the Device Setup tab. 

 

13.4.2.1 a. In the Comment field, enter 
the name of the logger. 

b. Select the relevant 
Sampling Rate.  

c. Select the relevant 
Transmission interval. 

d. Select 0 average points. 
e. Select the relevant 

Temperature unit. 
f. Select the relevant inputs 

to be measured. If 
selecting In-1, 2, 3 or 4, 
change the custom sensor 
name for the selected 
Sensor type. 

g. Click Setup and Run. 
 

Once the logger has been 
configured: 
a. Verify the Comment has 

been updated in the logger 
tooltip. 

b. Verify the logger is sampling 
at the defined sampling rate. 

c. Verify the logger is 
transmitting at the defined 
Transmission interval. 

d. If a temperature sensor was 
defined, verify the value is 
displayed in the correct unit 
in the logger tooltip. 

e. Verify the custom sensor 
name is displayed in the 
logger tooltip and in the 
Sensor View. 

 

13.4.3 Following 13.4.2.1, right-click 
the logger icon and select 
Setup. Select the Alarm Setup  
tab. 

a. Verify the Setup dialog is 
opened. 

b. Verify the same inputs 
configured in 10.4.2.1 are 
enabled in the Alarm Setup 
tab. 
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Test # Test Description Expected Result Result 

13.4.3.1 a. Select the relevant Alarm 
delay 

b. Select the relevant Alarm 
duration 

c. For at least one of the 
enabled sensor inputs, 
select at least one of the 
Low, Pre-Low, Pre-High 
and High alarm check 
boxes. Enter the relevant 
value in the alarm field. 

d. Click Setup and Run. 
 

Create the alarm conditions as 
defined in this test and verify the 
following: 
a. Logger alarm is activated 

after the defined alarm delay. 
b. Logger icon displays red 

alarm status 
c. Logger emits audible alarm 

for the defined duration 
d. DataSuite software alarm is 

audible (ensure the Alarm 
icon is unmuted in the upper 
toolbar) 

 

13.4.4 Place the mouse cursor over 
the online logger icon when the 
logger is running, to display the 
tooltip. 

Verify the tooltip contains the 
following information: 
a. Logger Part Number 
b. Logger Serial Number - 

matching the Serial Number 
on the rear of the unit casing 

c. Logger Comment 
d. Battery Level/Charging 

status 
e. Reception Quality 
f. Version – matching the 

firmware version displayed 
on the Logger LCD menu 

g. Last Sample Time – for each 
of the configured inputs 

 

13.4.5 With the logger running, right-
click the logger icon and select 
Display Data. 

Verify the online Graph View is 
opened and that the logger data 
is updated in real-time. 

 

13.4.6 Right-click the logger icon and 
select Download Data. 

Verify the data is downloaded 
from the logger memory to the 
online Graph View. When the 
logger is downloading the data, 
the Logger icon in Map View will 
display a green progress circle 
as follows:  

 
 

 

13.4.7 Right-click the logger icon and 
select Cancel Download during 
the download process. 

Verify the data download is 
halted. 

 

13.4.8 Right-click the logger icon and 
select Reset Alarm while the 
logger is in alarm status.  

Verify the logger icon changes 
from alarm status to normal 
status. If the logger is still in 
alarm status then the icon will 
immediately revert back to alarm 
status. 
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Test # Test Description Expected Result Result 

13.4.9 Right-click the logger icon and 
select Call Unit (Beep) (for 
DNL910 and DNL920 only) 

Verify the logger unit emits a 
beep for several seconds. 

 

13.4.10 Ensure a copy of the DataNet 
firmware is located in the 
DataSuite root directory. 
Right-click the logger icon and 
select Update Firmware. 
Enter the password and 
confirm firmware update. 

a. Verify that the firmware 
update process is performed 
on the logger. 

b. Following the firmware 
update, confirm the firmware 
version in the logger tooltip 
matches the firmware file 
that was updated. 

 

13.4.11 Right-click the logger icon and 
select Stop. 

Verify the logger has stopped 
running. 

 

13.4.12 With the logger in Stop mode, 
right-click the logger icon and 
select Calibration > Calibrate. 
Enter the system password. 

Verify the logger Calibration 
dialog is opened. 

 

13.4.13 Select the relevant sensor from 
the Sensor drop-down menu. 
Select the inputs to be 
calibrated (All inputs or a 
specific input) and click Setup. 

Verify the Calibration and 
Logger Data panes are enabled. 

 

13.4.14 Calibrate the input selected in 
13.4.13. Click Send 
Calibration at the end of the 
process. 

Verify the Logger Data pane 
displays the correctly calibrated 
values. 

 

13.4.15 Repeat 13.4.13 and 13.4.14 for 
each of the inputs to be 
calibrated. 

For each input, verify the Logger 
Data pane displays the correctly 
calibrated values. 

 

13.4.16 With the logger in Stop mode, 
right-click the logger icon and 
select Calibration > Save 
Calibration. 
Enter the system password. 
In the Save As dialog, enter 
the file name and click Save in 
the desired location. 

Verify the calibration file was 
saved in the correct location. 

 

13.4.17 With the logger in Stop mode, 
right-click the logger icon and 
select Calibration > Load 
Calibration. 
Enter the system password. 
In the Open dialog browse to 
the location of the calibration 
file to be loaded, and click 
Open. 

Verify the software loads the 
calibration file into the logger 
memory by looking at the logger 
tooltip Command Queue 
Process. 

 

13.4.18 With the logger in Stop mode, 
right-click the logger icon and 
select Calibration > Restore 
Factory Calibration Defaults. 
Enter the system password. 

Verify the default calibration 
values were restored to the 
logger memory. 
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Test # Test Description Expected Result Result 

13.4.19 Right-click the logger icon and 
select Leave Network. 

Verify the logger leaves the 
network and the icon disappears 
from the Map View. 

 

13.4.20 With the logger in Stop mode, 
right-click the logger icon and 
select Run. 

Verify the logger icon changes to 
Run status and the logger tooltip 
and online graph displays real-
time values. 

 

13.4.21 Right-click the logger icon and 
select Show Network Path. 

Verify the network path between 
the logger and the parent node 
is displayed. 

 

13.4.22 Right-click the logger icon and 
select Enable Short range 
Repeater Mode (only for 
DNL910 and DNL920). 
Enter the system password. 

Verify the logger tooltip displays 
SR Repeater Mode after the 
logger part number. 

 

13.4.22.1 Right-click the logger icon and 
select Disable Short range 
Repeater Mode (only for 
DNL910 and DNL920). 
Enter the system password. 

Verify the logger tooltip no 
longer displays SR Repeater 
Mode after the logger part 
number. 

 

13.5 DaqLink Logger Icon (Note: Skip this test if not using the DaqLink system)  

13.5.1 Connect a logger to the 
computer. 

Verify the online logger icon is 
displayed in the Map View. 

 

13.5.2 Right-click the logger icon and 
select Setup. Select the 
Device Setup tab. 

a. Verify the Setup dialog is 
opened. 

b. Verify the Serial Number and 
Firmware version are correct 
in the Device Setup tab. 

 

13.5.2.1 a. In the Comment field, enter 
the name of the logger. 

b. Select the relevant 
Sampling Rate.  

c. Select the relevant Memory 
State. 

d. Select 0 average points. 
e. Select the relevant 

Temperature unit. 
f. Select the relevant inputs 

to be measured. If 
selecting In-1, 2, 3 or 4, 
change the custom sensor 
name for the selected 
Sensor type. 

g. Click Setup and Run. 
 

Once the logger has been 
configured: 
a. Verify the Comment has 

been updated in the logger 
tooltip. 

b. Verify the logger is sampling 
at the defined sampling rate. 

c. Verify the logger data is 
being updated in real-time on 
the Graph View if memory 
state was set to Online 
Mode.  

d. If a temperature sensor was 
defined, verify the value is 
displayed in the correct unit 
in the logger tooltip. 

e. Verify the custom sensor 
name is displayed in the 
logger tooltip and in the 
Sensor View. 
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Test # Test Description Expected Result Result 

13.5.3 Following 13.5.2.1, right-click 
the logger icon and select 
Setup. Select the Alarm Setup  
tab. 

a. Verify the Setup dialog is 
opened. 

b. Verify the same inputs 
configured in 13.5.2.1 are 
enabled in the Alarm Setup 
tab. 

 

13.5.3.1 a. Select the relevant Alarm 
delay 

b. Select the relevant Alarm 
duration 

c. For at least one of the 
enabled sensor inputs, 
select at least one of the 
Low, Pre-Low, Pre-High 
and High alarm check 
boxes. Enter the relevant 
value in the alarm field. 

d. Click Setup and Run. 

Create the alarm conditions as 
defined in this test and verify the 
following: 
a. Logger alarm is activated 

after the defined alarm delay. 
b. Logger icon displays red 

alarm status 
c. Logger emits audible alarm 

for the defined duration 
d. DataSuite software alarm is 

audible (ensure the Alarm 
icon is unmuted in the upper 
toolbar) 

 

13.5.4 Place the mouse cursor over 
the online logger icon when the 
logger is running, to display the 
tooltip. 

Verify the tooltip contains the 
following information: 
a. Logger Part Number 
b. Logger Serial Number - 

matching the Serial Number 
on the rear of the unit casing 

c. Logger Comment 
d. Battery Level/Charging 

status 
e. Version – matching the 

firmware version displayed 
on the Logger LCD menu 

f. Last Sample Time – for each 
of the configured inputs 

 

13.5.5 With the logger running, right-
click the logger icon and select 
Display Data. 

Verify the online Graph View is 
opened and that the logger data 
is updated in real-time. 

 

13.5.6 Right-click the logger icon and 
select Download Data. 

Verify the data is downloaded 
from the logger memory to the 
online Graph View. When the 
logger is downloading the data, 
the Logger icon in Map View will 
display a green progress circle 
as follows:  

 
 

 

13.5.7 Right-click the logger icon and 
select Cancel Download during 
the download process. 

Verify the data download is 
halted. 
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Test # Test Description Expected Result Result 

13.5.8 Right-click the logger icon and 
select Reset Alarm while the 
logger is in alarm status.  

Verify the logger icon changes 
from alarm status to normal 
status. If the logger is still in 
alarm status then the icon will 
immediately revert back to alarm 
status. 

 

13.5.9 Ensure a copy of the DaqLink 
firmware is located in the 
DataSuite root directory. 
Right-click the logger icon and 
select Update Firmware. 
Enter the password and 
confirm firmware update. 

Verify that the firmware update 
process is performed on the 
logger. 
Following the firmware update, 
confirm the firmware version in 
the logger tooltip matches the 
firmware file that was updated. 

 

13.5.10 Right-click the logger icon and 
select Stop. 

Verify the logger has stopped 
running. 

 

13.5.11 With the logger in Stop mode, 
right-click the logger icon and 
select Calibration > Calibrate. 
Enter the system password. 

Verify the logger Calibration 
dialog is opened. 

 

13.5.12 Select the relevant sensor from 
the Sensor drop-down menu. 
Select the inputs to be 
calibrated (All inputs or a 
specific input) and click Setup. 

Verify the Calibration and 
Logger Data panes are enabled. 

 

13.5.13 Calibrate the input selected in 
13.5.3.1. Click Send 
Calibration at the end of the 
process. 

Verify the Logger Data pane 
displays the correctly calibrated 
values. 

 

13.5.14 Repeat 13.5.12 and 13.5.13 for 
each of the inputs to be 
calibrated. 

For each input, verify the Logger 
Data pane displays the correctly 
calibrated values. 

 

13.5.15 With the logger in Stop mode, 
right-click the logger icon and 
select Calibration > Save 
Calibration. 
Enter the system password. 
In the Save As dialog, enter 
the file name and click Save in 
the desired location. 

Verify the calibration file was 
saved in the correct location. 

 

13.5.16 With the logger in Stop mode, 
right-click the logger icon and 
select Calibration > Load 
Calibration. 
Enter the system password. 
In the Open dialog browse to 
the location of the calibration 
file to be loaded, and click 
Open. 

Verify the software loads the 
calibration file into the logger 
memory by looking at the logger 
tooltip Command Queue 
Process. 
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Test # Test Description Expected Result Result 

13.5.17 With the logger in Stop mode, 
right-click the logger icon and 
select Calibration > Restore 
Factory Calibration Defaults. 
Enter the system password. 

Verify the default calibration 
values were restored to the 
logger memory. 

 

13.5.18 With the logger in Stop mode, 
right-click the logger icon and 
select Run. 

Verify the logger icon changes to 
Run status and the logger tooltip 
and online graph displays real-
time values. 

 

13.6 MicroLite/MicroLogPRO II/PicoLite Logger Icon (Note: Skip this test if not 
using these systems)  

13.6.1 Connect a logger to the 
computer. 

Verify the online logger icon is 
displayed in the Map View. 

 

13.6.2 Right-click the logger icon and 
select Setup. Select the 
Properties tab. 

a. Verify the Setup dialog is 
opened. 

b. Verify the Serial Number and 
Firmware version are correct 
in the Properties tab. 

 

13.6.2.1 a. In the Comment field, enter 
the name of the logger. 

b. Select the relevant 
Sampling Rate.  

c. Select 0 average points. 
d. Select the relevant 

Temperature unit. 

See 13.6.2.4  

13.6.2.2 Select the Sensors tab. 
Select the relevant inputs to be 
measured.  

See 13.6.2.4  

13.6.2.3 Select the Display tab. 
Ensure Always On is selected. 
(Note: Skip this test for 
PicoLite) 

See 13.6.2.4  

13.6.2.4 Click Setup and Run. Once the logger has been 
configured: 
a. Verify the Comment has 

been updated in the logger 
tooltip. 

b. Verify the logger is sampling 
at the defined sampling rate. 

c. If a temperature sensor was 
defined, verify the value is 
displayed in the correct unit 
in the logger tooltip. 

 

13.6.3 Following 13.6.2.4, right-click 
the logger icon and select 
Setup. Select the Sensors tab. 

a. Verify the Setup dialog is 
opened. 

b. Verify the same inputs 
configured in 13.6.2.2 are 
enabled in the Sensors tab. 
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Test # Test Description Expected Result Result 

13.6.3.1 a. Select the relevant Alarm 
delay 

b. For at least one of the 
enabled sensor inputs, 
select the Alarm checkbox 
and enter the relevant Low 
or High value in the alarm 
field. 

c. Click Setup and Run. 

Create the alarm conditions as 
defined in this test and verify the 
following: 
a. Logger alarm is activated 

after the defined alarm delay. 
b. Logger icon displays red 

alarm status 
c. DataSuite software alarm is 

audible (ensure the Alarm 
icon is unmuted in the upper 
toolbar) 

 

13.6.4 Place the mouse cursor over 
the online logger icon when the 
logger is running, to display the 
tooltip. 

Verify the tooltip contains the 
following information: 
a. Logger Part Number 
b. Logger Serial Number - 

matching the Serial Number 
on the rear of the unit casing 

c. Logger Comment 
d. Battery Level 
e. Version – matching the 

firmware version displayed 
on the Logger LCD menu (if 
relevant) 

f. Last Sample Time – for each 
of the configured inputs 

 

13.6.5 With the logger running, right-
click the logger icon and select 
Display Data. 

Verify the online Graph View is 
opened and that the logger data 
is updated in real-time. 

 

13.6.6 Right-click the logger icon and 
select Download Data. 

Verify the data is downloaded 
from the logger memory to the 
online Graph View. When the 
logger is downloading the data, 
the Logger icon in Map View will 
display a green progress circle.  
 
 

 

13.6.7 Right-click the logger icon and 
select Cancel Download during 
the download process. 

Verify the data download is 
halted. 

 

13.6.8 Ensure a copy of the logger 
firmware is located in the 
DataSuite root directory. 
Right-click the logger icon and 
select Update Firmware. 
Enter the password and 
confirm firmware update. 

Verify that the firmware update 
process is performed on the 
logger. 
Following the firmware update, 
confirm the firmware version in 
the logger tooltip matches the 
firmware file that was updated. 

 

13.6.9 Right-click the logger icon and 
select Stop. 

Verify the logger has stopped 
running. 

 

13.6.10 With the logger in Stop mode, 
right-click the logger icon and 
select Calibration > Calibrate. 
Enter the system password. 

Verify the logger Calibration 
dialog is opened. 
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13.6.11 Select the relevant sensor from 
the Sensor drop-down menu. 
Select the inputs to be 
calibrated (All inputs or a 
specific input) and click Setup. 

Verify the Calibration and 
Logger Data panes are enabled. 

 

13.6.12 Calibrate the input selected in 
13.6.11. Click Send 
Calibration at the end of the 
process. 

Verify the Logger Data pane 
displays the correctly calibrated 
values. 

 

13.6.13 Repeat 13.6.11 and 13.6.12 for 
each of the inputs to be 
calibrated. 

For each input, verify the Logger 
Data pane displays the correctly 
calibrated values. 

 

13.6.14 For the MicroLogPRO II and 
MicroLite only, with the logger 
in Stop mode, right-click the 
logger icon and select 
Calibration > Restore 
Factory Calibration Defaults. 
Enter the system password. 

Verify the default calibration 
values were restored to the 
logger memory. 

 

13.6.15 With the logger in Stop mode, 
right-click the logger icon and 
select Run. 

Verify the logger icon changes to 
Run status and the logger tooltip 
and online graph displays real-
time values. 

 

14 – Change Password dialog 
 

Test # Test Description Expected Result Result 

14.1 Open the Password dialog. For 
example, go to Tools > 
Firmware Update Center. 

Verify the Password dialog is 
opened. 

 

14.2 Click Change Password. Verify the Change Password 
dialog is opened. 

 

14.3 Enter the old password and then 
enter the new password in the 
New and Confirm password 
fields. 
Click OK. 

Verify that the new password is 
accepted and that the dialog 
originally selected in 14.1 is 
opened. 
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